FANDOM


Introduction

When producing wiki pages for items, it's easy to forget the importance of a good, high-quality picture. A good picture allows a busy reader to instantly identify the object described by the article and delivers a satisfying visual experience. However, a pixelated, low resolution photo is ambiguous and instigates doubts about the legitimacy of source.

See for yourself: Which image below features a flare? Hover the image with your cursor for the correct answer.

Fuseorflare

Inspect mode

Creating good photos of inventory items is extremely easy thanks to the inspect feature found in the inventory menu. The inspect mode allows players to zoom in and rotate an inventory item, while displaying its information on the left and right. As you might have noticed, objects are always centered on the screen in the same orientation, even after zooming in.

Fo4 inspect mode


Tutorial: creating high-quality images of inventory items

This tutorial aims to demonstrate how aforementioned high-quality images of inventory items can be created with ease. The main technique introduced requires an image manipulation program which supports the Difference blend mode. I will be using Photoshop, but I see no reason why a free alternative like GIMP wouldn't work.

Step 1. Take your screenshots

We're going to need two screenshots of the item in the exact same position and orientation with different backgrounds. It's important that the backgrounds are as different as possible. An easy option is to go with one being entirely white (or light grey) and the other entirely black.

A white background is easy to achieve by using tcl in the console and flying as close to a light source as possible. A black background can be created by utilizing the slight exposure shift delay when looking away from lights after staring at them for a few seconds.

I've created videos for your convenience demonstrating the methods for the white and black backgrounds.

Here are the screenshots I ended up with:

Example cryo white Example cryo black
Even though the white background doesn't extend to fill the entire screen, it covers the background of the item sufficiently.

Step 2. Creating the layer mask

  1. Import both images to your image manipulation program of choice. As mentioned before, I personally chose Photoshop.
  2. Make sure that the two images are aligned and on two separate layers.
  3. Set the layer blend mode of the top layer (order is irrelevant) to Difference. If your images are not aligned or the items weren't in the exact same position and orientation, this is where you're going to notice it. If the item is completely black, you're good to go.
    Step2-3
  4. Duplicate the top layer, hide the new layer, then merge the two bottom layers. Now you should have two layers: one containing one of your original screenshots and the other containing the difference.
  5. Select the difference layer and select Image -> Adjustments -> Levels. In GIMP, find the effect from Colors -> Levels. Pull the grey (center) slider to the left until it is approximately between the center and the black slider on the left. Pull the white slider (right) towards the left until the background under all edges of the item is completely white. Video demonstrating this.

Step 3. Applying the layer mask

  1. Use Select -> Color Range (In GIMP, use the Select By Color tool) to select the black color on the difference layer. Pull up the fuzziness to 200% (experiment with the values if this gives you unsatisfactory results).
  2. Show the top layer and click on the "Add layer mask" button while you still have the selection active (In GIMP, Layer -> Mask -> Add Layer Mask, then choose Selection from the radio buttons). Hide the difference layer below. You've now cut out the item from the background! The mask still needs some refinement, though.
    Step3-2
  3. Double-click on the layer mask thumbnail to bring up the Properties panel, then click on Mask Edge.... This step can also be done immediately after selecting the black color by going to Select -> Refine Edge...
    Step3-3
  4. This varies by the item's edges' roughness and roundness, but usually I've had good results by using "Smooth" of 1, "Feather" of 1px, "Contrast" of 44% and "Shift Edge" of -8%. Experiment with the values to get a well-defined edge. Smoothness rounds the edges of the selection, so be wary when creating cutouts of items with lots of sharp edges.

Step 4. Finishing up

  1. Remove all the remaining things like text outside your item.
  2. Hide all other layers except for your newly cut item layer. Use Image -> Trim to trim excess white space.
  3. Add a margin of 50-100px depending on your item's size. Do this after trimming by going to Image -> Canvas Size..., ticking "Relative" and adding the margin to both the width and height. If the item is very tall (a bottle, for instance), you may want to add some extra margin to the width so that the image looks better in infoboxes.
    Step4-margin
  4. Open File -> Save for Web, choose PNG-24 from the top right menu, make sure "Transparency" is ticked, then save the image.
    Step4-save

Step 5. Uploading

Go to the Special:Upload page and upload your image. Important: Read the banners visible on the page!

Photoshop Action

I've captured this tutorial as a Photoshop CC action, which can be used to automate the process almost entirely. To use it, bring your two screenshots into Photoshop as two separate layers, and name the top layer 1 and the bottom layer 2. After running the action, all you need to do is crop the item!

Download the action here!

Blog-post-action-help

Blog-post-action-help2

Thanks

Thank you for taking the time to read this post. Thrive to contribute high-quality content.