FANDOM


This talk page is only for discussing improvements to the page "A New Threat."
Talkpage
  • It is not the place for general discussion or sharing stories about the topic of this article. Please use our forum for these purposes.
  • Please sign and date your posts by typing four tildes (~~~~) after each of your entries.
  • Put new text under old text. Click here to start a new topic.
  • Do not edit other people's entries.

Trouble with radar beacons Edit

Has anybody experienced an issue of not being able to install the radar beacon to Ada? --Taolan (talk) 05:17, March 23, 2016 (UTC)

Yeah no matter what I do my game just won't update the quest upon installing the radar beacon. So far I have run without mods, ran without console commands, ran with brand new installation of Fallout 4, and ran on a brand new save file. Nothing works. I don't understand what is the problem but my quest just won't update. What could be causing this? I have no progressed the Automatron DLC at all because of this bug. It's extremely frustrating. 173.69.36.141 01:38, March 25, 2016 (UTC)
The problem happens to me on my 2nd playthrough now, there just ain't an option in the menu to install the beacon. --Rautamiekka (talk) 16:55, February 14, 2018 (UTC)
Did you try the workaround, i.e. scrap all existing robot workbenches at all settlements and build a new one? IIRC there's some bug which only considers the first workbench built as a valid quest alias. Aya42 (talk) 17:05, February 14, 2018 (UTC)
Yep, tried just now it multiple ways: scrapped it after creating it in Sanctuary (it wanted it made at Red Rocket instead), rebuilt, scrapped, then went to Red Rocket and built, then reloaded a save from before building it and built at Red Rocket with identical result. --Rautamiekka (talk) 19:45, February 14, 2018 (UTC)

──────────────────────────────────────────────────────────────────────────────────────────────────── Hmm. I had the same problem on my first playthrough, and the only way I could fix it was to revert to a save before getting the robot workbench schematics, then ensuring that I didn't build one until required in A New Threat stage 2500. Then I built one, and only one, and used that for the rest of the questline. Aya42 (talk) 20:04, February 14, 2018 (UTC)

Ok, reloaded a save from before I got that schematic but the menu still has just 'Legs' despite always doing like the quest journal says in order. --Rautamiekka (talk) 17:26, February 15, 2018 (UTC)
Odd. Which settlement did you send Ada to, and which settlement did you build the workbench at? Aya42 (talk) 17:53, February 15, 2018 (UTC)
Sent her to Sanctuary (we were standing in the middle of it), and the game always wanted the workbench at Red Rocket in this playthrough unlike in Sanctuary in the previous one. Built it there the second time, with identical result. --Rautamiekka (talk) 18:16, February 15, 2018 (UTC)
I think Red Rocket is Ada's default location (i.e. when you first get the option to send her somewhere, if you cancel out instead of picking a location), so maybe that's something to do with it?
I'll can take a look at the game script files, but they're on another PC which I can't get to for a couple of days. I presume you're not on PC, cos there are simpler workarounds for that. Until then, other than restarting the automatron quests from scratch and sending her to Red Rocket instead, I can't think of anything else. Aya42 (talk) 18:57, February 15, 2018 (UTC)
I am on PC. --Rautamiekka (talk) 19:25, February 15, 2018 (UTC)

──────────────────────────────────────────────────────────────────────────────────────────────────── Oh. So does setstage DLC01MQ02 2900 not work? Aya42 (talk) 19:53, February 15, 2018 (UTC)

That worked. The menu didn't change though. --Rautamiekka (talk) 20:16, February 18, 2018 (UTC)
Had a quick look through the scripts. There's a function UpdateRobotWorkbench in DLC01MQ00Script.psc which seems to control which workbench is deemed to be the quest alias RobotWorkbench for this quest. I'm guessing the option only appears if using the workbench assigned to this alias. You can check the value with sqv DLC01MQ02. Aya42 (talk) 17:04, February 19, 2018 (UTC)

Search the robobrain Edit

Anyone have the problem of not being able to advance past searching the robobrain? After searching and getting the mechanist device it still prompts me to search the robobrain and I cannot advance any farther. Also I'm on Xbox one so console commands are not an option. —Preceding unsigned comment added by 162.251.197.240 (talkcontribs). Please sign your posts with ~~~~!

No definitive solution for consoles yet, although there was some speculation that this only occurs if you build the robot workbench before the point in the quest where it requires you to. Aya42 (talk) 06:46, March 28, 2016 (UTC)