Wikia

Nukapedia

Problems with Fallout 3 GOTY & Windows 7

17,659pages on
this wiki

Forum page

Forums: Index > Fallout 3 gameplay help > Problems with Fallout 3 GOTY & Windows 7
 
Gametitle-FO3
Gametitle-FO3

Fellow vault dwellers. I've played and completed Fallout 3 (and the DLC) on the PS3, and was sick to death of all the constant lock-ups & crashes, on the console version. So, I thought I'd treat myself to the PC variant. I'm having problems with installing Fallout 3 GOTY with Windows 7 Ultimate Edition 64 bit. I can install disc one with no problems. It starts up with the screen flashing, 'Windows 7 has changed to basic mode' (Am I right in thinking this is turning off Areo?) and then the game fires up, and plays for 'HOURS' without crashing or locking-up. This is without the 1.7 patch.

On to disc 2. This is where my problems start. If I install from the disc, the DLC. (and waiting for the PC to read the disc). After the install, Windows is reporting that the install has failed and has not been installed correctly. I start my game and it will lock-up, and it wont even get to the main menu screen. IE: Play, Tech Help etc.. Just two small black windows. Also I loose the mouse, then have to Ctrl Alt + Del to the task manager, to end the process. Even installing the 1.7 patch afterwards, causes the exact same problem. All my graphic & soundcard drivers are up to date to my knowledge, along with everything else, ie mouse/keyboard blar blar blar. I've spent DAYS trawling the net, and not one of the solutions I've found has worked. And all of their variants!

Copy DLC to a folder & install from there.

The Windows Live bug fix.

The d3d9.dll fix. Which just changed my graphics card in the game from an ATI to a Nvidia.

Install disc 1, then patch, then disc 2.

Tried both the UK & US 1.7 patches.

The My Games\Fallout3\fallout.ini add and save

fForegroundMouseAccelBase=0.0000 fForegroundMouseAccelTop=0.0000 fForegroundMouseBase=0.0000 fForegroundMouseMult=4.0000

The no CD patch, as a last resort.

I've forgoten how many times I've uninstalled, then reinstalled! All this grief because of the DLC & 1.7 patch. Any help would be greatly appreciated. Also, I'm thinking of getting Fallout New Vegas. (not from Steam) Am I going to have the same problems again, with that?

Many thanks.

My PC Specs (Not the greatest for gaming, I know).

Windows 7 Ultimate Edition 64 bit. (Without Service pack 1, because it's a pain in the a**)

AMD Phenom X4 Quad-Core 3.2

Gigabyte 870A-UD3 Motherboard

ATI Radeon HD 5450 Graphics Card 1024 ram (Over 2 monitors 14" for Desktop & 19" for main and gaming).

16 gig of Kingston DDR3 ram

Sound Blaster X-Fi Xtreme Soundcard


I really cannot help you out in terms of getting the game to work however I can tell you that judging by your RAM you should be fine in running the game, I understand the graphics card and soundcard are important for running games but the RAM is kinda the main thing.

Azzy G33 15:50, March 22, 2012 (UTC)

Thanks for the reply Azzy G33 I have finally got the game working with all the DLC. I disabled the second monitor (14" one) and BINGO! It all installed. Also, I installed Fallout New Vegas, and it runs perfect! Happy Trails to me....

Fallout Jules 15:51, March 23, 2012 (UTC)

Well then Fallout Jules maybe you can help me out, I also have a GOTY edition of the game however when I go to enable to DLC it ticks them all but as I click okay it unticks them and i don't know how to sort it out. Azzy G33 18:02, March 23, 2012 (UTC)

Okay. This is what worked for me. I had already stated a game to get things running. IE: I escaped the vault etc, and the DLC still didn't show. So after disabling the second monitor, I could install the DLC and then sign in to Windows Live, which then said there was downloads available. I exited 'Live' but my game continue wasn't there from the previous session, so I had to start a fresh. But at the start-up screen of the game menu where it says download content, I ticked all the boxes, but NOT THE VERY BOTTOM ONE. From what I've read on the interwebnets, the DLC will not start until you have 'escaped from the fault. After this, the DLC 'should' kick in.

Fallout Jules 16:29, March 23, 2012 (UTC)


Okay I will try this :) and I will let you know if it works, thank you very much :)

Other Wikia wikis

Random Wiki